lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <>
Subject [jira] Commented: (LUCENE-2530) rename docsEnum.getBulkResult() to make its role clearer
Date Fri, 09 Jul 2010 10:50:50 GMT


Michael McCandless commented on LUCENE-2530:

I agree, we should rename it, to make it clear it's mandatory that you call it.  I like prepareBulkResult.

> rename docsEnum.getBulkResult() to make its role clearer
> --------------------------------------------------------
>                 Key: LUCENE-2530
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Bug
>          Components: Index
>    Affects Versions: 4.0
>            Reporter: Andi Vajda
>            Assignee: Michael McCandless
>            Priority: Minor
>             Fix For: 4.0
> Before can be called a BulkResult instance must be allocated for it (it
== the default implementation of that method).
> This is done by calling docsEnum.getBulkResult(). Failure to call this method before
read() is called results in a NullPointerException.
> It is somewhat counterintuitive to "get" the results of an operation before calling said
> Maybe this method should be renamed to something more definite-sounding like obtainBulkResult()
or prepareBulkResult() ?

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message