lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (JIRA)" <>
Subject [jira] Updated: (LUCENE-2191) rename Tokenizer.reset(Reader) to Tokenizer.setReader(Reader)
Date Thu, 27 Jan 2011 10:13:44 GMT


Uwe Schindler updated LUCENE-2191:

    Fix Version/s: 4.0

I think we should simply do this in trunk (4.0), no backwards problems! reset(Reader) is the
wrong name and confuses people (especially if it should include reset() or not - correct is
that it should *not* also call reset() - I fixed lots of Tokenizers like StandardTokenizer
to conform to this)

> rename Tokenizer.reset(Reader) to Tokenizer.setReader(Reader)
> -------------------------------------------------------------
>                 Key: LUCENE-2191
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: contrib/analyzers
>            Reporter: Robert Muir
>            Priority: Minor
>             Fix For: 4.0
> in TokenStream there is a reset() method, but the method in Tokenizer used to set a new
Reader is called reset(Reader).
> in my opinion this name overloading creates a lot of confusion, and we see things like
reset(Reader) calling reset() even in StandardTokenizer...
> So I think this would be some work to fulfill all the backwards compatibility, but worth
it because when you look at the existing reset(Reader) and reset() code in various tokenizers,
or the javadocs for Tokenizer, its pretty confusing and inconsistent.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message