lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Mark Nemeskey (JIRA)" <j...@apache.org>
Subject [jira] [Created] (LUCENE-3173) Rename some classes and methods in the search package so their names describe their roles
Date Sun, 05 Jun 2011 13:44:47 GMT
Rename some classes and methods in the search package so their names describe their roles
-----------------------------------------------------------------------------------------

                 Key: LUCENE-3173
                 URL: https://issues.apache.org/jira/browse/LUCENE-3173
             Project: Lucene - Java
          Issue Type: Improvement
          Components: core/search
    Affects Versions: flexscoring branch
            Reporter: David Mark Nemeskey
            Assignee: David Mark Nemeskey
            Priority: Trivial


In an IRC discussion with Robert Muir, it has come up that the names of certain classes and
methods in the search package do not describe the role of the class or method in question.
Therefore, we propose the following name changes:
- Scorer to Matcher
- Similarity.computeWeight() to Similarity.computeStats()
- Similarity.DocScorer to Similarity.Scorer*

(*) Under consideration.

The reason for the name computeStats() is that this method will be used by the new Similarity
subclasses to compute all the statistics they need, not just idf.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message