lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "DM Smith (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3454) rename optimize to a less cool-sounding name
Date Sun, 25 Sep 2011 18:14:26 GMT


DM Smith commented on LUCENE-3454:

When I started w/ Lucene, I read the docs and was drawn to call optimize because of its "cool
name." However, it was reading the documentation at the time that convinced me that it was
appropriate for my use case:

Creating an index that once created would never be modified. It needed to be as fast as possible
for search on low performance computing devices (old laptops, ancient computers, netbooks,
phones, ...).

Maybe I misunderstood, but wasn't it and isn't it still appropriate for that?

And I have no idea what NooSegments means.

If you want a really uncool name how about dumbDown()?

But either way, please document the appropriate use cases for it.

> rename optimize to a less cool-sounding name
> --------------------------------------------
>                 Key: LUCENE-3454
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>    Affects Versions: 4.0
>            Reporter: Robert Muir
> I think users see the name optimize and feel they must do this, because who wants a suboptimal
system? but this probably just results in wasted time and resources.
> maybe rename to collapseSegments or something?

This message is automatically generated by JIRA.
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message