lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hoss Man (JIRA)" <>
Subject [jira] [Resolved] (SOLR-1751) SpatialSearch: documented example is not working
Date Wed, 13 Jun 2012 23:39:43 GMT


Hoss Man resolved SOLR-1751.

       Resolution: Not A Problem
    Fix Version/s:     (was: 4.0)

looks like this was just a transient issue with the wiki not reflecting reality for a breif
time back when spatial was still very new.

i'm not much of a spatial expert, but i just skimmed the wiki and didn't see any mention of
the(non-existent) "point" function and none of the examples that i tried caused any errors.
> SpatialSearch: documented example is not working
> ------------------------------------------------
>                 Key: SOLR-1751
>                 URL:
>             Project: Solr
>          Issue Type: Bug
>          Components: search
>    Affects Versions: 1.5
>         Environment: Windows
>            Reporter: Brainski
>              Labels: SpatialSearch
> I downloaded the nightly build from 03. February 2010 and tried the example as documented
> I imported all documents under exampledocs in the index.
> Then I tried the following search request:
> http://localhost:8983/solr/select/?q=_val_:"recip(dist(2, store, point(34.0232,-81.0664)),1,1,0)"&fl=*,score
> ----------------------
> This leads to the following error:
> org.apache.lucene.queryParser.ParseException: Cannot parse '_val_:"recip(dist(2, store,
point(34.0232,-81.0664)),1,1,0)"': Unknown function point in FunctionQuery('recip(dist(2,
store, point(34.0232,-81.0664)),1,1,0)', pos=27)
> RequestURI=/solr/select/
> ----------------------------------

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message