lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (JIRA)" <>
Subject [jira] [Created] (LUCENE-4307) rename IR.getTopReaderContext to IR.getContext
Date Tue, 14 Aug 2012 02:19:38 GMT
Robert Muir created LUCENE-4307:

             Summary: rename IR.getTopReaderContext to IR.getContext
                 Key: LUCENE-4307
             Project: Lucene - Core
          Issue Type: Task
            Reporter: Robert Muir
         Attachments: LUCENE-4307.patch

IR/IS.getTopReaderContext is supposed to read as "get the ReaderContext, with this reader
treated as the top". 

But every time I look at it, it reads as "get context of the top-level reader". 

This makes sense for IndexSearcher, but is confusing for IndexReader.

I think it should simply be IR.getContext() for IndexReader.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message