lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Debray (JIRA)" <>
Subject [jira] [Created] (SOLR-4980) Improve method names on SolrQuery
Date Mon, 01 Jul 2013 09:44:19 GMT
Daniel Debray created SOLR-4980:

             Summary: Improve method names on SolrQuery
                 Key: SOLR-4980
             Project: Solr
          Issue Type: Improvement
          Components: clients - java
    Affects Versions: 5.0
            Reporter: Daniel Debray
            Priority: Trivial
             Fix For: 5.0

The setter method names for the field statistics in the SolrQuery class are a little bit confusing
and i think they should be renamed. 

I think a setter method should set a field to a given value and not just add a value to the
existing field. For this behavior, an add method is more convinent.

A patch is applyed to this issue. If you think is is not needed, just close this issue :).

The existing setter methods are set to deprecated and some documentation is added to explain
their behavior.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message