lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-5124) fix+document+rename DiskDV to Lucene45
Date Fri, 19 Jul 2013 17:10:48 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-5124?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13713852#comment-13713852
] 

Michael McCandless commented on LUCENE-5124:
--------------------------------------------

+1
                
> fix+document+rename DiskDV to Lucene45
> --------------------------------------
>
>                 Key: LUCENE-5124
>                 URL: https://issues.apache.org/jira/browse/LUCENE-5124
>             Project: Lucene - Core
>          Issue Type: New Feature
>    Affects Versions: 4.5
>            Reporter: Robert Muir
>
> The idea is that the default implementation should not hold everything in memory, we
can have a "Memory" impl for that. I think stuff being all in heap memory is just a relic
of FieldCache.
> In my benchmarking diskdv works well, and its much easier to manage (keep a smaller heap,
leave it to the OS, no OOMs etc from merging large FSTs, ...)
> If someone wants to optimize by forcing everything in memory, they can then use the usual
approach (e.g. just use FileSwitchDirectory, or pick "Memory" for even more efficient stuff).
> Ill keep the issue here for a bit. If we decide to do this, ill work up file format docs
and so on. We should also fix a few things that are not great about it (LUCENE-5122) before
making it the default.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message