Hi Bill,

We are using SOLR-2155 patch in solr3.6 for quite long time. This works well for us. We are currently migrating to Solr 4.0. Is this SOLR-2345 is equivalent of  SOLR-2155 in terms of functionality?

Thanks


From: David Smiley (JIRA) <jira@apache.org>
To: dev@lucene.apache.org
Sent: Tuesday, July 16, 2013 10:20 PM
Subject: [jira] [Updated] (SOLR-2345) Extend geodist() to support MultiValued lat long field


    [ https://issues.apache.org/jira/browse/SOLR-2345?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

David Smiley updated SOLR-2345:
-------------------------------

    Attachment: SOLR-2345_geodist_support_for_RPT.patch

The attached patch implements the desired functionality.  It depends on LUCENE-5118 being applied first.

This hack wasn't too terrible after all.
               
> Extend geodist() to support MultiValued lat long field
> ------------------------------------------------------
>
>                Key: SOLR-2345
>                URL: https://issues.apache.org/jira/browse/SOLR-2345
>            Project: Solr
>          Issue Type: New Feature
>          Components: spatial
>            Reporter: Bill Bell
>            Assignee: David Smiley
>            Fix For: 4.5
>
>        Attachments: SOLR-2345_geodist_refactor.patch, SOLR-2345_geodist_support_for_RPT.patch
>
>
> Extend geodist() and {!geofilt} to support a multiValued lat,long field without using geohash.
> sort=geodist() asc

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org