lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (JIRA)" <>
Subject [jira] [Commented] (LUCENE-5554) Add TermBulkScorer
Date Tue, 25 Mar 2014 23:57:16 GMT


Robert Muir commented on LUCENE-5554:

Well I'm not really sure its specialization. IMO these two methods are different things, and
should probably be named as such: score() and scoreRange() or something. 

They take different parameters and have different return values.

Its just the case (which I did not notice) in LUCENE-5487, that one is changed to call the
other to try to shoehorn them into one method. Thats why i said, we should investigate cleaning
this up better: all this patch does is "undo the shoehorning".

But we don't need to duplicate term scorer nor change the API if we don't really want to.

> Add TermBulkScorer
> ------------------
>                 Key: LUCENE-5554
>                 URL:
>             Project: Lucene - Core
>          Issue Type: Improvement
>          Components: core/search
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>             Fix For: 4.8, 5.0
>         Attachments: LUCENE-5554.patch, LUCENE-5554.patch
> Hotspot was unhappy with the changes in LUCENE-5487, e.g.:
> But it looks like we can get the performance back by making a dedicated BulkScorer for

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message