lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Matheis (steffkes) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SOLR-5897) JQuery file listed as version 1.7.2 but actually contains 1.4.3 code
Date Sun, 20 Apr 2014 19:01:15 GMT

     [ https://issues.apache.org/jira/browse/SOLR-5897?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Stefan Matheis (steffkes) updated SOLR-5897:
--------------------------------------------

    Fix Version/s: 4.9
         Assignee: Stefan Matheis (steffkes)

I'm going to commit this tomorrow

> JQuery file listed as version 1.7.2 but actually contains 1.4.3 code
> --------------------------------------------------------------------
>
>                 Key: SOLR-5897
>                 URL: https://issues.apache.org/jira/browse/SOLR-5897
>             Project: Solr
>          Issue Type: Bug
>          Components: web gui
>    Affects Versions: 4.1, 4.2, 4.2.1, 4.3, 4.3.1, 4.4, 4.5, 4.5.1, 4.6, 4.6.1, 4.7
>         Environment: All
>            Reporter: Jonathan Lampe
>            Assignee: Stefan Matheis (steffkes)
>            Priority: Minor
>              Labels: jquery, war
>             Fix For: 4.9
>
>         Attachments: SOLR-5897.patch
>
>
> The "example\webapps\solr.war" file contains a "jquery-1.7.2.min.js" file whose name
suggests that it is version 1.7.2.  However, the file actually contains version 1.4.3 code.
 (This code may be subject to CVE-2011-4969.) 
> (I think I read something about a functional roll-back from JQuery 1.5.1 to 1.4.3 in
other issues - if so, could possibly be related?)   



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message