lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pradeep K Poluri (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (LUCENE-5566) Inconsistent search results in different threads but same query
Date Wed, 02 Apr 2014 21:23:14 GMT

     [ https://issues.apache.org/jira/browse/LUCENE-5566?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Pradeep K Poluri updated LUCENE-5566:
-------------------------------------

    Description: 
We have a very difficult case to identify whats going on.
We have a multithreaded environment where multiple threads are trying to hit the same lucene
query and getting different results each time.
For eg: Query A has returned 1 result which is running in thread 1
    And same Query A is returning 0 results which is running in thread 2.

All the indexes looks fine and if we take the same query and try it in Luke and we are able
to get the correct results which is 1 in this case. And we are not able to reproduce it in
local environments or staging or integration but only on Production.

Trying to figure out whats going on. 

  was:
We have a very difficult case to identify whats going on.
We have a multithreaded environment where multiple threads are trying to hit the same lucene
query and getting different results each time.
For eg: Query A has returned 1 result which is running in thread 1
    And same Query A is returning 0 results which is running in thread 2.

All the indexes looks fine and if we take the same query and try it in Luke and we are able
to get the correct results which is 1 in this case.

Trying to figure out whats going on. 


> Inconsistent search results in different threads but same query
> ---------------------------------------------------------------
>
>                 Key: LUCENE-5566
>                 URL: https://issues.apache.org/jira/browse/LUCENE-5566
>             Project: Lucene - Core
>          Issue Type: Bug
>          Components: core/search
>    Affects Versions: 3.6
>            Reporter: Pradeep K Poluri
>
> We have a very difficult case to identify whats going on.
> We have a multithreaded environment where multiple threads are trying to hit the same
lucene query and getting different results each time.
> For eg: Query A has returned 1 result which is running in thread 1
>     And same Query A is returning 0 results which is running in thread 2.
> All the indexes looks fine and if we take the same query and try it in Luke and we are
able to get the correct results which is 1 in this case. And we are not able to reproduce
it in local environments or staging or integration but only on Production.
> Trying to figure out whats going on. 



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message