lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-5569) Rename AtomicReader to LeafReader
Date Thu, 03 Apr 2014 18:55:14 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-5569?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13959083#comment-13959083
] 

Michael McCandless commented on LUCENE-5569:
--------------------------------------------

+1

> Rename AtomicReader to LeafReader
> ---------------------------------
>
>                 Key: LUCENE-5569
>                 URL: https://issues.apache.org/jira/browse/LUCENE-5569
>             Project: Lucene - Core
>          Issue Type: Improvement
>            Reporter: Adrien Grand
>            Priority: Minor
>             Fix For: 5.0
>
>
> See LUCENE-5527 for more context: several of us seem to prefer {{Leaf}} to {{Atomic}}.
> Talking from my experience, I was a bit confused in the beginning that this thing is
named {{AtomicReader}}, since {{Atomic}} is otherwise used in Java in the context of concurrency.
So maybe renaming it to {{Leaf}} would help remove this confusion and also carry the information
that these readers are used as leaves of top-level readers?



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message