lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ryan Ernst (JIRA)" <>
Subject [jira] [Updated] (LUCENE-5569) Rename AtomicReader to LeafReader
Date Sat, 05 Apr 2014 05:33:16 GMT


Ryan Ernst updated LUCENE-5569:

    Attachment: LUCENE-5569.patch


I was also confused like Adrien, thinking atomic had something to do with concurrency.  I've
attached a patch, just to see what scope this has.  It is pretty massive, but it also only
took about 2 minutes using IntelliJ.

I think the major bump to 5 is the perfect time to do this type of renaming.  Yes renaming
presents a burden on consumers, but refactoring for clarity and ease of entry for new developers
outweighs that burden, IMO.

> Rename AtomicReader to LeafReader
> ---------------------------------
>                 Key: LUCENE-5569
>                 URL:
>             Project: Lucene - Core
>          Issue Type: Improvement
>            Reporter: Adrien Grand
>            Priority: Minor
>             Fix For: 5.0
>         Attachments: LUCENE-5569.patch
> See LUCENE-5527 for more context: several of us seem to prefer {{Leaf}} to {{Atomic}}.
> Talking from my experience, I was a bit confused in the beginning that this thing is
named {{AtomicReader}}, since {{Atomic}} is otherwise used in Java in the context of concurrency.
So maybe renaming it to {{Leaf}} would help remove this confusion and also carry the information
that these readers are used as leaves of top-level readers?

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message