lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (LUCENE-5569) Rename AtomicReader to LeafReader
Date Sat, 05 Apr 2014 12:52:15 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-5569?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13961076#comment-13961076
] 

Uwe Schindler edited comment on LUCENE-5569 at 4/5/14 12:50 PM:
----------------------------------------------------------------

Hi,
I also tend to aggree with Yonik and Tim. In general I would also prefer to rename it, but
the work needed for users is big with having no new features. A pure rename is useless. Unfortunately
i was the one who added that name in the big IndexReader refactoring. But at that time we
all agreed on that name.
But we should have thought better about it. LeafReader is fine, especially becaus ethe other
APIs already use leave: Like {{ReaderContext#leaves()}}.
If we really want to rename that, we should do this shortly before the release of 5.0. Otherwise
merging might be much harder from trunk to 4.x. As this is just an eclipse rename of 2 classes
(AtomicReader, AtomicReaderContext), this is not much work, just an Eclipse-automatism. The
remaining classes is the same: FilterAtomicReader, and various test-only readers.


was (Author: thetaphi):
Hi,
I also tend to aggree with Yonik and Tim. In general I would also prefer to rename it. Unfortunately
i was the one who added that name in the big IndexReader refactoring. But at that time we
all agreed on that name.
But we should have thought better about it. LeafReader is fine, especially becaus ethe other
APIs already use leave: Like {{ReaderContext#leaves()}}.
If we really want to rename that, we should do this shortly before the release of 5.0. Otherwise
merging might be much harder from trunk to 4.x. As this is just an eclipse rename of 2 classes
(AtomicReader, AtomicReaderContext), this is not much work, just an Eclipse-automatism. The
remaining classes is the same: FilterAtomicReader, and various test-only readers.

> Rename AtomicReader to LeafReader
> ---------------------------------
>
>                 Key: LUCENE-5569
>                 URL: https://issues.apache.org/jira/browse/LUCENE-5569
>             Project: Lucene - Core
>          Issue Type: Improvement
>            Reporter: Adrien Grand
>            Priority: Minor
>             Fix For: 5.0
>
>         Attachments: LUCENE-5569.patch
>
>
> See LUCENE-5527 for more context: several of us seem to prefer {{Leaf}} to {{Atomic}}.
> Talking from my experience, I was a bit confused in the beginning that this thing is
named {{AtomicReader}}, since {{Atomic}} is otherwise used in Java in the context of concurrency.
So maybe renaming it to {{Leaf}} would help remove this confusion and also carry the information
that these readers are used as leaves of top-level readers?



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message