lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ryan Ernst (JIRA)" <>
Subject [jira] [Created] (SOLR-6022) Rename getAnalyzer to getIndexAnalyzer
Date Fri, 25 Apr 2014 21:25:15 GMT
Ryan Ernst created SOLR-6022:

             Summary: Rename getAnalyzer to getIndexAnalyzer
                 Key: SOLR-6022
             Project: Solr
          Issue Type: Improvement
            Reporter: Ryan Ernst

We have separate index/query analyzer chains, but the access methods for the analyzers do
not match up with the names.  This can lead to unknowingly using the wrong analyzer chain
(as it did in SOLR-6017).  We should do this renaming in trunk, and deprecate the old getAnalyzer
function in 4x.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message