lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ryan Ernst (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SOLR-6022) Rename getAnalyzer to getIndexAnalyzer
Date Sat, 26 Apr 2014 06:36:14 GMT

     [ https://issues.apache.org/jira/browse/SOLR-6022?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ryan Ernst updated SOLR-6022:
-----------------------------

    Attachment: SOLR-6022.patch

Here's a patch against trunk that does the rename for IndexSchema and FieldType.  When merging
back to branch_4x I'll add getAnalyzer back with as deprecated.

> Rename getAnalyzer to getIndexAnalyzer
> --------------------------------------
>
>                 Key: SOLR-6022
>                 URL: https://issues.apache.org/jira/browse/SOLR-6022
>             Project: Solr
>          Issue Type: Improvement
>            Reporter: Ryan Ernst
>         Attachments: SOLR-6022.patch
>
>
> We have separate index/query analyzer chains, but the access methods for the analyzers
do not match up with the names.  This can lead to unknowingly using the wrong analyzer chain
(as it did in SOLR-6017).  We should do this renaming in trunk, and deprecate the old getAnalyzer
function in 4x.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message