lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ryan Ernst (JIRA)" <>
Subject [jira] [Updated] (SOLR-6022) Rename getAnalyzer to getIndexAnalyzer
Date Mon, 28 Apr 2014 19:00:21 GMT


Ryan Ernst updated SOLR-6022:

    Attachment: SOLR-6022.branch_4x-deprecation.patch

Here are two more patches:
# The first is still for trunk, and changes the indexAnalyzer/queryAnalyzer members in FieldType
to private scope.  This will be a "hard fail" for anyone that is subclassing FieldType and
using these, but they should be using get/setAnalyzer anyways.  It also adds CHANGES.txt entries
for review.
# The second patch shows exactly how I will do the deprecation in branch_4x (I believe I should
be able to just apply the patch after doing a merge back from trunk).

> Rename getAnalyzer to getIndexAnalyzer
> --------------------------------------
>                 Key: SOLR-6022
>                 URL:
>             Project: Solr
>          Issue Type: Improvement
>            Reporter: Ryan Ernst
>         Attachments: SOLR-6022.branch_4x-deprecation.patch, SOLR-6022.patch, SOLR-6022.patch
> We have separate index/query analyzer chains, but the access methods for the analyzers
do not match up with the names.  This can lead to unknowingly using the wrong analyzer chain
(as it did in SOLR-6017).  We should do this renaming in trunk, and deprecate the old getAnalyzer
function in 4x.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message