lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ryan Ernst (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-6022) Rename getAnalyzer to getIndexAnalyzer
Date Wed, 30 Apr 2014 21:11:17 GMT

    [ https://issues.apache.org/jira/browse/SOLR-6022?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13986089#comment-13986089
] 

Ryan Ernst commented on SOLR-6022:
----------------------------------

bq. I am not sure if this should be the IndexAnalyzer or the QueryAnalyzer as AFAIR, this
tries to construct a query out of the terms from a document (given an id).

I only kept what was there before.  I don't know enough about MLT to make a statement whether
it is correct or not.  If it is broken, I think another jira should be opened?

> Rename getAnalyzer to getIndexAnalyzer
> --------------------------------------
>
>                 Key: SOLR-6022
>                 URL: https://issues.apache.org/jira/browse/SOLR-6022
>             Project: Solr
>          Issue Type: Improvement
>            Reporter: Ryan Ernst
>         Attachments: SOLR-6022.branch_4x-deprecation.patch, SOLR-6022.patch, SOLR-6022.patch,
SOLR-6022.patch
>
>
> We have separate index/query analyzer chains, but the access methods for the analyzers
do not match up with the names.  This can lead to unknowingly using the wrong analyzer chain
(as it did in SOLR-6017).  We should do this renaming in trunk, and deprecate the old getAnalyzer
function in 4x.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message