lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ryan McKinley (JIRA)" <>
Subject [jira] [Commented] (LUCENE-5771) Review semantics of SpatialOperation predicates
Date Fri, 20 Jun 2014 07:07:24 GMT


Ryan McKinley commented on LUCENE-5771:

change looks good

I *think* the reason for  "queryNeedsArea" and "targetNeedsArea" was so that we could decide
if the input was valid simply based on the shape -- but i think we find that out anyway, so
we could just drop these.

I don't think 'scoreIsMeaningful' is used, so it can also be dropped

> Review semantics of SpatialOperation predicates
> -----------------------------------------------
>                 Key: LUCENE-5771
>                 URL:
>             Project: Lucene - Core
>          Issue Type: Improvement
>          Components: modules/spatial
>            Reporter: David Smiley
>         Attachments: LUCENE-5771_SpatialOperation_semantics.patch
> SpatialOperation (which I wish was named SpatialPredicate) is a bunch of predicates --
methods that return true/false based on a pair of shapes.  Some of them don't seem to be defined
in a way consistent with their definitions on ESRI's site:
>  (which
is linked as a reference, and is in turn equivalent to OGC spec definitions, I believe).
> Problems:
> * the definitions make no mention of needing to have area or not, yet some of our predicates
are defined as to require area on either the indexed or query shape.
> * the definitions make a distinction of the boundary of a shape, yet in Lucene-spatial,
there is none.  That suggests our predicates are wrongly chosen since there *are* official
predicates that are boundary-neutral -- namely "Covers" and "CoveredBy" in lieu of Contains
and Within, respectively.  If we don't rename our predicates, we should at least support the
correct predicates names!
> * Overlaps appears totally wrong. It should be defined as indexedShape.relate(queryShape)
== Intersects  (and thus not Within or Contains or Disjoint).  It's presently defined as the
same as Intersects plus the query shape needing area.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message