lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <>
Subject [jira] [Commented] (LUCENE-5569) Rename AtomicReader to LeafReader
Date Tue, 23 Sep 2014 23:52:35 GMT


ASF subversion and git services commented on LUCENE-5569:

Commit 1627178 from [~rjernst] in branch 'dev/trunk'
[ ]

LUCENE-5569: *AtomicReader/AtomicReaderContext have been renamed to *LeafReader/LeafReaderContext

> Rename AtomicReader to LeafReader
> ---------------------------------
>                 Key: LUCENE-5569
>                 URL:
>             Project: Lucene - Core
>          Issue Type: Improvement
>            Reporter: Adrien Grand
>            Priority: Blocker
>             Fix For: Trunk
>         Attachments: LUCENE-5569.patch, LUCENE-5569.patch
> See LUCENE-5527 for more context: several of us seem to prefer {{Leaf}} to {{Atomic}}.
> Talking from my experience, I was a bit confused in the beginning that this thing is
named {{AtomicReader}}, since {{Atomic}} is otherwise used in Java in the context of concurrency.
So maybe renaming it to {{Leaf}} would help remove this confusion and also carry the information
that these readers are used as leaves of top-level readers?

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message