lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erick Erickson (JIRA)" <>
Subject [jira] [Commented] (SOLR-6670) change BALANCESLICEUNIQUE to BALANCESHARDUNIQUE
Date Sun, 02 Nov 2014 20:39:33 GMT


Erick Erickson commented on SOLR-6670:

I don't see any problem with changing this even though it'll change the names of a couple
of parameters to the collections API since it hasn't been released yet.

I'll be checking these changes in today probably.

> -----------------------------------------------
>                 Key: SOLR-6670
>                 URL:
>             Project: Solr
>          Issue Type: Improvement
>            Reporter: Erick Erickson
>            Assignee: Erick Erickson
>            Priority: Minor
> JIRA for Jan's comments on SOLR-6513:
> I thought we agreed to prefer the term "shard" over "slice", so I think we should do
this for this API as well.
> The only place in our refguide we use the word "slice" is in How SolrCloud Works [1]
and that description is disputed.
> The refguide explanation of what a shard is can be found in Shards and Indexing Data
in SolrCloud [2], quoting:
> When your data is too large for one node, you can break it up and store it in sections
by creating one or more shards. Each is a portion of the logical index, or core, and it's
the set of all nodes containing that section of the index.
> So I'm proposing a rename of this API to BALANCESHARDUNIQUE and a rewrite of [1].
> [1]
> [2]
> Note Mark's comment on that JIRA, but I think it would be best to continue to talk about
"shards" with user-facing operations.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message