lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anshum Gupta <ans...@anshumgupta.net>
Subject Re: [VOTE] 5.0.0 RC2
Date Tue, 10 Feb 2015 17:14:24 GMT
This is strange. It works for me on my mac.

On Tue, Feb 10, 2015 at 9:00 AM, Chris Hostetter <hossman_lucene@fucit.org>
wrote:

>
> : That part of the script expects you run from the root of a checkout.  It
> : runs the backcompat tests, and scrapes the test output to check all are
> : tested.
>
> Everything you said made sense, and i even filed LUCENE-6234 to note that
> we should improve the behavior -- and yet even when i run smokeTester from
> the root of my lucene_solr_5_0 checkout, i get the same error...
>
>
>
>
> hossman@frisbee:~/lucene/branch_5_0$ svn update
> U    dev-tools/scripts/smokeTestRelease.py
>  U   dev-tools
>  U   .
> Updated to revision 1658755.
> hossman@frisbee:~/lucene/branch_5_0$ python3.2
> dev-tools/scripts/smokeTestRelease.py
>
> http://people.apache.org/~anshum/staging_area/lucene-solr-5.0.0-RC2-rev1658469
> Java 1.7 JAVA_HOME=/usr/lib/jvm/java-7-openjdk-amd64/
> NOTE: output encoding is UTF-8
>
> Load release URL
> "
> http://people.apache.org/~anshum/staging_area/lucene-solr-5.0.0-RC2-rev1658469
> "...
>   unshortened:
>
> http://people.apache.org/~anshum/staging_area/lucene-solr-5.0.0-RC2-rev1658469/
>
> Test Lucene...
>   test basics...
>   get KEYS
>     0.1 MB in 0.64 sec (0.2 MB/sec)
>   check changes HTML...
>   download lucene-5.0.0-src.tgz...
>     27.9 MB in 5.13 sec (5.4 MB/sec)
>     verify md5/sha1 digests
>     verify sig
>     verify trust
>       GPG: gpg: WARNING: This key is not certified with a trusted
> signature!
>   download lucene-5.0.0.tgz...
>     64.0 MB in 29.27 sec (2.2 MB/sec)
>     verify md5/sha1 digests
>     verify sig
>     verify trust
>       GPG: gpg: WARNING: This key is not certified with a trusted
> signature!
>   download lucene-5.0.0.zip...
>     73.5 MB in 22.35 sec (3.3 MB/sec)
>     verify md5/sha1 digests
>     verify sig
>     verify trust
>       GPG: gpg: WARNING: This key is not certified with a trusted
> signature!
>   unpack lucene-5.0.0.tgz...
>     verify JAR metadata/identity/no javax.* or java.* classes...
>     test demo with 1.7...
>       got 5647 hits for query "lucene"
>     checkindex with 1.7...
>     check Lucene's javadoc JAR
>   unpack lucene-5.0.0.zip...
>     verify JAR metadata/identity/no javax.* or java.* classes...
>     test demo with 1.7...
>       got 5647 hits for query "lucene"
>     checkindex with 1.7...
>     check Lucene's javadoc JAR
>   unpack lucene-5.0.0-src.tgz...
>     make sure no JARs/WARs in src dist...
>     run "ant validate"
>     run tests w/ Java 7 and testArgs=''...
>     test demo with 1.7...
>       got 210 hits for query "lucene"
>     checkindex with 1.7...
>     generate javadocs w/ Java 7...
>
> Crawl/parse...
>
> Verify...
>   confirm all releases have coverage in TestBackwardsCompatibility
>     find all past Lucene releases...
>     run TestBackwardsCompatibility..
> Releases that don't seem to be tested:
>   2.0.0
>   2.1.0
>   2.2.0
>   2.3.0
>   2.4.0
>   2.4.1
>   2.9.0
>   2.9.1
>   2.9.2
>   2.9.3
>   2.9.4
>   3.0.0
>   3.0.1
>   3.0.2
>   3.0.3
>   3.1.0
>   3.2.0
>   3.3.0
>   3.4.0
>   3.5.0
>   3.6.0
>   3.6.1
>   3.6.2
>   4.0.0
>   4.0.0.0
>   4.0.0.1
>   4.1.0
>   4.2.0
>   4.2.1
>   4.3.0
>   4.3.1
>   4.4.0
>   4.5.0
>   4.5.1
>   4.6.0
>   4.6.1
>   4.7.0
>   4.7.1
>   4.7.2
>   4.8.0
>   4.8.1
>   4.9.0
>   4.9.1
>   4.10.0
>   4.10.1
>   4.10.2
>   4.10.3
> Traceback (most recent call last):
>   File "dev-tools/scripts/smokeTestRelease.py", line 1530, in <module>
>     main()
>   File "dev-tools/scripts/smokeTestRelease.py", line 1475, in main
>     smokeTest(c.java, c.url, c.revision, c.version, c.tmp_dir,
> c.is_signed, ' '.join(c.test_args))
>   File "dev-tools/scripts/smokeTestRelease.py", line 1513, in smokeTest
>     unpackAndVerify(java, 'lucene', tmpDir, 'lucene-%s-src.tgz' % version,
> svnRevision, version, testArgs, baseURL)
>   File "dev-tools/scripts/smokeTestRelease.py", line 623, in
> unpackAndVerify
>     verifyUnpacked(java, project, artifact, unpackPath, svnRevision,
> version, testArgs, tmpDir, baseURL)
>   File "dev-tools/scripts/smokeTestRelease.py", line 804, in
> verifyUnpacked
>     confirmAllReleasesAreTestedForBackCompat(unpackPath)
>   File "dev-tools/scripts/smokeTestRelease.py", line 1468, in
> confirmAllReleasesAreTestedForBackCompat
>     raise RuntimeError('some releases are not tested by
> TestBackwardsCompatibility?')
> RuntimeError: some releases are not tested by TestBackwardsCompatibility?
> hossman@frisbee:~/lucene/branch_5_0$ svn info .
> Path: .
> URL: https://svn.apache.org/repos/asf/lucene/dev/branches/lucene_solr_5_0
> Repository Root: https://svn.apache.org/repos/asf
> Repository UUID: 13f79535-47bb-0310-9956-ffa450edef68
> Revision: 1658755
> Node Kind: directory
> Schedule: normal
> Last Changed Author: sarowe
> Last Changed Rev: 1658727
> Last Changed Date: 2015-02-10 07:44:56 -0700 (Tue, 10 Feb 2015)
>
>
>
>
>
>
>
>
> -Hoss
> http://www.lucidworks.com/
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: dev-help@lucene.apache.org
>
>


-- 
Anshum Gupta
http://about.me/anshumgupta

Mime
View raw message