lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hoss Man (JIRA)" <>
Subject [jira] [Commented] (LUCENE-6227) Add BooleanClause.Occur.FILTER
Date Mon, 09 Feb 2015 17:28:35 GMT


Hoss Man commented on LUCENE-6227:

two tangential thoughts/questions...

1) From an API/conceptual standpoint, does it make more sense for this to be a new "Occur"
instance (the Occur.FILTER here) or would it make more sense for this to be a property on
BooleanClause that could be set to true with either MUST or MUST_NOT clauses?

2) Assuming it's a new Occur.FILTER, should we plan on renaming Occur.MUST_NOT to something
like Occur.FILTER_NEGATION since (unless i'm missunderstanding something) the "non-scoring"
semantics of Occur.FILTER and Occur.MUST_NOT are basicly the inverse of each other right?
 so it seems like we should probably do something ot make it more clear that Occur.MUST_NOT
has more in common with FILTER then with MUST ?

> Add BooleanClause.Occur.FILTER
> ------------------------------
>                 Key: LUCENE-6227
>                 URL:
>             Project: Lucene - Core
>          Issue Type: Improvement
>            Reporter: Adrien Grand
>            Assignee: Adrien Grand
>            Priority: Minor
>             Fix For: Trunk, 5.1
>         Attachments: LUCENE-6227.patch, LUCENE-6227.patch, LUCENE-6227.patch
> Now that we have weight-level control of whether scoring is needed or not, we could add
a new clause type to BooleanQuery. It would behave like MUST exept that it would not participate
in scoring.
> Why do we need it given that we already have FilteredQuery? The idea is that by having
a single query that performs conjunctions, we could potentially take better decisions. It's
not ready to replace FilteredQuery yet as FilteredQuery has handling of random-access filters
that BooleanQuery doesn't, but it's a first step towards that direction and eventually FilteredQuery
would just rewrite to a BooleanQuery.
> I've been calling this new clause type FILTER so far, but feel free to propose a better

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message