lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-6614) IOUtils.spins doesn't work for drives NVMe drives
Date Fri, 26 Jun 2015 14:26:05 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-6614?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14602934#comment-14602934
] 

Michael McCandless commented on LUCENE-6614:
--------------------------------------------

I tested the patch with a small standalone Java static main, and confirmed I get "true" before,
and "false" with the patch!  Thank you [~thetaphi]!

> IOUtils.spins doesn't work for drives NVMe drives
> -------------------------------------------------
>
>                 Key: LUCENE-6614
>                 URL: https://issues.apache.org/jira/browse/LUCENE-6614
>             Project: Lucene - Core
>          Issue Type: Bug
>            Reporter: Michael McCandless
>            Assignee: Uwe Schindler
>            Priority: Minor
>             Fix For: 5.3, Trunk
>
>         Attachments: LUCENE-6614.patch, LUCENE-6614.patch
>
>
> NVMe is the faster (than AHCI) protocol for newer SSDs that plug into the PCIE bus.
> I just built a new beast box with one of these drives, and the partition is named {{/dev/nvme0n1p1}}
while the device is {{/dev/nvme0n1}} by Linux - this also appears in /sys/block with rotational=0.
> I think [~steve_rowe] also has an NVME drive ...
> [~thetaphi] (who got the box working for me: thank you!!!) has ideas on how to fix it!



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message