lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Noble Paul (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-6722) Java 8 as the minimum supported JVM version for branch_5x
Date Thu, 06 Aug 2015 11:57:05 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-6722?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14659894#comment-14659894
] 

Noble Paul commented on LUCENE-6722:
------------------------------------

If it is a 6.0 that we need to move to java 8, let's move to 6.0. There is no reason why we
should not use modern language features in our code because it is harder to apply the patch
on to branch_5x

So how is it going to be?
5.3 , 5.4 and then 6.0 ?

> Java 8 as the minimum supported JVM version for branch_5x
> ---------------------------------------------------------
>
>                 Key: LUCENE-6722
>                 URL: https://issues.apache.org/jira/browse/LUCENE-6722
>             Project: Lucene - Core
>          Issue Type: Wish
>            Reporter: Shalin Shekhar Mangar
>            Priority: Blocker
>             Fix For: 5.4
>
>
> Require Java 8 as the minimum supported JVM version for branch_5x.
> # Java 7 is already EOL'ed
> # Trunk is already at Java8
> # Important Solr components such as Jetty 9.3.x already require Java 8
> # Nashorn Javascript engine available in Java 8 is just so much faster and we may see
more usage of JS inside Solr (SOLR-7576 etc.)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message