lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Høydahl (JIRA) <j...@apache.org>
Subject [jira] [Commented] (LUCENE-6722) Java 8 as the minimum supported JVM version for branch_5x
Date Thu, 06 Aug 2015 22:59:05 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-6722?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14660937#comment-14660937
] 

Jan Høydahl commented on LUCENE-6722:
-------------------------------------

One potential justification for a 6.x would be revolutionizing our query parser stack, going
all-in with Flex parsers, and adding true NEAR and ANY operator support (and perhaps others
as well) to the default Lucene/Solr parsers (LUCENE-1823 and friends). Guess that aligns with
the work of [~romseygeek] too? I know too little about the details to make a formal suggestion,
just throwing in some ideas.

> Java 8 as the minimum supported JVM version for branch_5x
> ---------------------------------------------------------
>
>                 Key: LUCENE-6722
>                 URL: https://issues.apache.org/jira/browse/LUCENE-6722
>             Project: Lucene - Core
>          Issue Type: Wish
>            Reporter: Shalin Shekhar Mangar
>            Priority: Blocker
>             Fix For: 5.4
>
>
> Require Java 8 as the minimum supported JVM version for branch_5x.
> # Java 7 is already EOL'ed
> # Trunk is already at Java8
> # Important Solr components such as Jetty 9.3.x already require Java 8
> # Nashorn Javascript engine available in Java 8 is just so much faster and we may see
more usage of JS inside Solr (SOLR-7576 etc.)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message