lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Johannes Brucher (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-8449) Restore functionality not working
Date Thu, 21 Jan 2016 08:27:39 GMT

    [ https://issues.apache.org/jira/browse/SOLR-8449?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15110268#comment-15110268
] 

Johannes Brucher commented on SOLR-8449:
----------------------------------------

I uploaded the document via the Admin UI/Core/Documents tab.
I think using this tab will automatically perform a commit in the background I guess, because
after adding the doc is in the index.

But to answer your question, after step 4 i did not explicitly call a commit statment!

> Restore functionality not working
> ---------------------------------
>
>                 Key: SOLR-8449
>                 URL: https://issues.apache.org/jira/browse/SOLR-8449
>             Project: Solr
>          Issue Type: Bug
>          Components: replication (java), replication (scripts)
>    Affects Versions: 5.2.1, 5.4
>         Environment: SUSE Linux Enterprise Server 11 (64 bit) and Windows 7 Prof SP1
>            Reporter: Johannes Brucher
>            Priority: Critical
>         Attachments: log_windows7_sp1.txt
>
>
> Hi all, I facing the following issue with Solr 5.2.1 and the ongoing version 5.4.
> The restore functionality is not working under Linux and causing an exception on Windows
machines each time you want to restore an existing backup twice or even more.
> Steps to reproduce:
> 1. Start a Solr instance pointing the solr_home to e.g. the example-DIH  folder.
> 2. Select a core, e.g. the “solr” core.
> 3. Switch to the “Documents” tab
> 4. Add a document {“id”:”1”,”title”:”change.me”}
> 5. Do a backup with the following API call “/solr/replication?command=backup&name=test”
> The backup defaults to the location solr_home/solr/data/snapshot.test
> 6. Add a document to the index {“id”:”2”,”title”:”change.me”}. Now there
a two document in the index.
> 7. Restore the back with the following call “/solr/replication?command=restore&name=test”
> New index location “solr_home/solr/data/restore.snapshot.test” is created without
any physical file in it, except the file write.lock. Num Docs is now 1 as expected!
> 8. Add a document to the index {“id”:”3”,”title”:”change.me”}. Now there
a two document in the index.
> 9. Restore the same previous created back again with the following call “/solr/replication?command=restore&name=test”.
Notice, there are still 2 docs in the index!!!
> 10. Try to restore again, but still the same, 2 docs in the index…
> 11. Shut down Solr, you will see the index folder “solr_home/solr/data/restore.snapshot.test”
disappears.
> 12. Restart Solr. You will notice the following log entry “Solr index directory ‘solr_home/solr/data/restore.snapshot.test’
doesn’t exist. Creating new index”, and indeed the Index is empty, showing 0 documents.
> 13. After the restart, I tried to restore the existing backup again without any results…
> I thing this behavior in not intended!!!
> Even more Problems arise when you run Solr on a Windows machine.
> After step 10 a folder “index” is created under “solr_home/solr/data/” with a
write.lock file in it. After that, the following exception is thrown: 
> …Error closing IndexWriter
> java.lang.IllegalStateException: file: MMapDirectory@D:\solr\Solr_versions\solr-5.2.1\...restore.snapshot.test
lockFactory=org.apache.lucene.store.Nat
> iveFSLockFactory@3d3d7a0e appears both in delegate and in cache
> The log file from the Windows test is attached.
> Let me know if you have problems reproducing the same behavior,
> Regards Johannes



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message