lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yonik Seeley <ysee...@gmail.com>
Subject Re: Removing branch_5x shortly
Date Sat, 20 Feb 2016 20:58:21 GMT
On Sat, Feb 20, 2016 at 3:42 PM, Michael McCandless
<lucene@mikemccandless.com> wrote:
> But if we do that then the (already released) 6.0 won't be able to
> read 5.6 indices, which I think would be very bad.

For sure, forward compatibility would need to apply.
That still leaves open a wide range of features at both the Lucene and
Solr level though.  If someone wanted to release a 5.6 that wasn't
forward compatible (to the degree that 5.5 will be) that would be a
reason to vote against it.

If, on the other hand, a future 5.6 would not be forward compatible by
the mere fact that it's called "5.6" then that should be fixed now,
before 6.0 is released.  We shouldn't be forced to preclude additional
5.x releases.

-Yonik

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message