lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shai Erera (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-8621) solrconfig.xml: deprecate/replace <mergePolicy> with <mergePolicyFactory>
Date Mon, 08 Feb 2016 12:33:39 GMT

    [ https://issues.apache.org/jira/browse/SOLR-8621?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15136886#comment-15136886
] 

Shai Erera commented on SOLR-8621:
----------------------------------

{quote}
Unrelated to the above, just pushed changes to MergePolicyFactoryArgs which will do away with
the need to change SolrPluginUtils but still keep MergePolicyFactoryArgs as an abstraction
which just happens to be implemented via a NamedList at the moment.
{quote}

I actually prefer that we not extend the usage of {{NamedList}} :). Really what we need is
a {{Map<String,Object>}} (which {{NamedList}} is also), so why introduce it in this
class? Would you mind if we switch back to Map? I also think that some of the changes to {{SolrPluginUtils}},
e.g. the refactoring of the {{findMethod}} method, contributed to its code readability, so
I'd like to restore them too. And finally, we we move back to a Map, then {{keys()}} don't
need to create a new {{HashSet}}.

bq. BTW, I thought that we can have wrapped.key optional and default to 'delegate' if one
isn't specified.

I take it back for now. Currently, if {{wrapper.key}} is not specified, we assume a default
wrapped MP should be used. We can still make {{wrapper.key}} optional, but I don't mind if
we defer that change for now. It can always be made optional later.

> solrconfig.xml: deprecate/replace <mergePolicy> with <mergePolicyFactory>
> -------------------------------------------------------------------------
>
>                 Key: SOLR-8621
>                 URL: https://issues.apache.org/jira/browse/SOLR-8621
>             Project: Solr
>          Issue Type: Task
>            Reporter: Christine Poerschke
>            Assignee: Christine Poerschke
>
> *<mergePolicyFactory> end-user benefits:*
> * Lucene's UpgradeIndexMergePolicy can be configured in Solr
> * (with SOLR-5730) Lucene's SortingMergePolicy can be configured in Solr
> * customisability: arbitrary merge policies including wrapping/nested merge policies
can be created and configured
> *(proposed) roadmap:*
> * solr 5.5 introduces <mergePolicyFactory> support
> * solr 5.5(\?) deprecates (but maintains) <mergePolicy> support
> * solr 6.0(\?) removes <mergePolicy> support 
> +work-in-progress git branch:+ [master-solr-8621|https://github.com/apache/lucene-solr/tree/master-solr-8621]



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message