lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Heisey <apa...@elyograg.org>
Subject Re: solr.common.util.Pair --> commons.lang3.tuple.Pair
Date Thu, 05 May 2016 17:01:22 GMT
On 5/5/2016 10:38 AM, Erick Erickson wrote:
> Even for a trivial class, +1 to going to the commons version if it
> doesn't include a new dependency.

Solr currently has commons-lang 2.6 as a dependency.  The class
mentioned in the subject says "lang3" ... so I think that would be a new
dependency.  It would probably coexist with 2.6, but adding another 2
megabytes to the download size for a trivial class does not seem like a
good idea.

Shawn


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message