lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tim Parker (JIRA)" <j...@apache.org>
Subject [jira] [Created] (SOLR-9231) SolrInputDocument no-args constructor removed without notice
Date Mon, 20 Jun 2016 18:15:58 GMT
Tim Parker created SOLR-9231:
--------------------------------

             Summary: SolrInputDocument no-args constructor removed without notice
                 Key: SOLR-9231
                 URL: https://issues.apache.org/jira/browse/SOLR-9231
             Project: Solr
          Issue Type: Bug
          Components: SolrJ
    Affects Versions: 6.1
         Environment: Lucee (or ColdFusion) loading SolrJ using separate URLClassLoader instance)
            Reporter: Tim Parker


In 6.0.1 and previous, SolrInputDocument provided two constructors - one with no arguments,
the other accepting a Map object.  As of 6.1.0, the no-arguments constructor is replaced with
one that accepts zero or more strings.

With 6.0.1, this worked:

cls = LoadClass("org.apache.solr.common.SolrInputDocument");

Constructor foo = cls.getConstructor();

This fails with Solr 6.1.0

We get the same error after updating the code to this:

cls = LoadClass("org.apache.solr.common.SolrInputDocument");

Class[] argArray = new Class[0];
Constructor foo = cls.getConstructor(argArray);

Are we missing something?  If not, please restore the missing no-arguments constructor.









--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message