lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ishan Chattopadhyaya (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-8581) Integration tests for rolling upgrades
Date Mon, 23 Jan 2017 10:02:26 GMT

    [ https://issues.apache.org/jira/browse/SOLR-8581?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15834185#comment-15834185
] 

Ishan Chattopadhyaya commented on SOLR-8581:
--------------------------------------------

I tested 6.2.0 -> 6.3.0 and 5.5.1 -> 6.3.0, and both passed.
However, 6.3.0 -> 6.4.0 is failing. Isn't obvious why, would need to look deeper if this
is a test problem or a genuine bug.

>  Integration tests for rolling upgrades
> ---------------------------------------
>
>                 Key: SOLR-8581
>                 URL: https://issues.apache.org/jira/browse/SOLR-8581
>             Project: Solr
>          Issue Type: Test
>            Reporter: Vivek Narang
>
> I intend to work on an integration test suite for Solr, to test for issues to deal with
back compat, rolling upgrades etc.
> The interface for the test suite, as I'm planning, would be to have it accept two versions
of Solr (either released versions or trunk/branch).
> I work on SolrCloud, and we need something like this to enable us to upgrade more frequently.
I had a conversation with @Ishan Chattopadhyaya, who emphasised to me the need to have something
like this.
> If there's already any ongoing effort in doing this, I can help out there. Please let
me know.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message