lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Julian Hyde (JIRA)" <>
Subject [jira] [Commented] (SOLR-9893) EasyMock/Mockito no longer works with Java 9 b148+
Date Sat, 07 Jan 2017 18:59:58 GMT


Julian Hyde commented on SOLR-9893:

We are running into the same issue in Calcite/Avatica: CALCITE-1567. Do you know if there
is a Mockito bug logged for this? Somewhere in someone
suggests that it is fixed in a later version of Mockito. If so I would like to upgrade to
that version of Mockito.

> EasyMock/Mockito no longer works with Java 9 b148+
> --------------------------------------------------
>                 Key: SOLR-9893
>                 URL:
>             Project: Solr
>          Issue Type: Bug
>      Security Level: Public(Default Security Level. Issues are Public) 
>          Components: Tests
>    Affects Versions: 6.x, master (7.0)
>            Reporter: Uwe Schindler
>            Priority: Blocker
> EasyMock does not work anymore with latest Java 9, because it uses cglib behind that
is trying to access a protected method inside the runtime using setAccessible. This is no
longer allowed by Java 9.
> Actually this is really stupid. Instead of forcefully making the protected defineClass
method available to the outside, it is much more correct to just subclass ClassLoader (like
the Lucene expressions module does).
> I tried updating to easymock/mockito, but all that does not work, approx 25 tests fail.
The only way is to disable all Mocking tests in Java 9. The underlying issue in cglib is still
not solved, master's code is here:
> As we use an old stone-aged version of mockito (1.x), a fix is not expected to happen,
although cglib might fix this!
> What should we do? This stupid issue prevents us from testing Java 9 with Solr completely!

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message