lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Elschot (JIRA)" <>
Subject [jira] [Commented] (LUCENE-7633) Rename Terms to IndexedField (was to FieldTerms)
Date Sat, 28 Jan 2017 12:31:24 GMT


Paul Elschot commented on LUCENE-7633:

The problem I have with the name Terms is that it is too general, it should be a little more
I think IndexedField is a good name for what it provides: term enumeration and term statistics.
The other renames just follow this.

In doing this I learned quite a bit about flexible indexing, and I really like the class structure.
With that behind me, I don't really need this renaming any more...

The renames are straightforward, so adopting them elsewhere should be easy.
In case these names are actually preferred, I'd gladly add backward compatible class names.
That would probably boil down to inserting classes with the current names as deprecated superclasses.

> Rename Terms to IndexedField (was to FieldTerms)
> ------------------------------------------------
>                 Key: LUCENE-7633
>                 URL:
>             Project: Lucene - Core
>          Issue Type: Improvement
>            Reporter: Paul Elschot

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message