lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Elschot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-7633) Rename Terms to FieldTerms
Date Wed, 18 Jan 2017 16:39:26 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-7633?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15828371#comment-15828371
] 

Paul Elschot commented on LUCENE-7633:
--------------------------------------

The Terms javadocs:

bq. Access to the terms in a specific field. See also Fields

But Terms does more than accessing the terms of a field, it also provides index statistics
for a field.
So in the o.a.l.index package, Field might actually be better name, but that would be confusing
with o.a.l.document.Field.

Perhaps this would be ideal:
Rename Fields to IndexedFields
Rename Terms to IndexedField

The current patch to rename Terms to FieldTerms changes 860 occurrences in 290 source code
files,
so there is no point in keeping this open for a longer period.
I'll close in two weeks or so, unless there are other opinions.

> Rename Terms to FieldTerms
> --------------------------
>
>                 Key: LUCENE-7633
>                 URL: https://issues.apache.org/jira/browse/LUCENE-7633
>             Project: Lucene - Core
>          Issue Type: Improvement
>            Reporter: Paul Elschot
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message