lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Markus Jelsma (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-10089) bin/solr script refuses to start due to PID file
Date Thu, 02 Feb 2017 11:54:51 GMT

    [ https://issues.apache.org/jira/browse/SOLR-10089?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15849832#comment-15849832
] 

Markus Jelsma commented on SOLR-10089:
--------------------------------------

Hello Jan - my machine was behaving very badly, so i took out the power cord. After starting
up again, i got this:

{code}
$ bin/solr  restart -c
Sending stop command to Solr running on port 8983 ... waiting up to 180 seconds to allow Jetty
process 2340 to stop gracefully.
java.net.ConnectException: Connection refused
        at java.net.PlainSocketImpl.socketConnect(Native Method)
        at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:345)
        at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
        at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
        at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
        at java.net.Socket.connect(Socket.java:589)
        at java.net.Socket.connect(Socket.java:538)
        at java.net.Socket.<init>(Socket.java:434)
        at java.net.Socket.<init>(Socket.java:244)
        at org.eclipse.jetty.start.Main.stop(Main.java:512)
        at org.eclipse.jetty.start.Main.stop(Main.java:491)
        at org.eclipse.jetty.start.Main.doStop(Main.java:479)
        at org.eclipse.jetty.start.Main.start(Main.java:403)
        at org.eclipse.jetty.start.Main.main(Main.java:75)

Usage: java -jar start.jar [options] [properties] [configs]
       java -jar start.jar --help  # for more information
 [-]  ^C
{code}

Weird, so i tried stop:

{code}
$ bin/solr  stop

Found 1 Solr nodes running! Must either specify a port using -p or -all to stop all Solr nodes
on this host.
{code}

Solr wasn't running, but i tried the following anyway:

{code}
$ bin/solr  stop -a
^C
{code}

Above call was just hanging, doing nothing. I then spotted the PID file:

{code}
$ rm bin/solr-8983.pid  
$ bin/solr  restart -c
Archiving 1 old GC log files to /home/markus/dev/solr-6.4.0/solr/server/logs/archived
Archiving 1 console log files to /home/markus/dev/solr-6.4.0/solr/server/logs/archived
Rotating solr logs, keeping a max of 9 generations
Waiting up to 180 seconds to see Solr running on port 8983 [\]  
Started Solr server on port 8983 (pid=4835). Happy searching!
{code}

All was fine again.

> bin/solr script refuses to start due to PID file
> ------------------------------------------------
>
>                 Key: SOLR-10089
>                 URL: https://issues.apache.org/jira/browse/SOLR-10089
>             Project: Solr
>          Issue Type: Bug
>      Security Level: Public(Default Security Level. Issues are Public) 
>    Affects Versions: 6.4
>            Reporter: Markus Jelsma
>             Fix For: master (7.0)
>
>
> The bin/solr script believes Solr is still running due to the PID file being present.
Solr was forcefully killed so the PID file is still there, but the service is obviously not
running.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message