lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ishan Chattopadhyaya (JIRA)" <>
Subject [jira] [Commented] (SOLR-6630) Deprecate the "implicit" router and rename to "manual"
Date Thu, 01 Jun 2017 09:38:04 GMT


Ishan Chattopadhyaya commented on SOLR-6630:

> Anything is better than "implicit".
I like "explicit" better than "manual", since "manual" has the implication than it needs to
be set "by hand", which is not exactly the case if done through user's SolrJ program (which
then becomes "programmatic" rather than "by hand"). I think this difference is subtle, and
I'm -0 on "manual".

> Deprecate the "implicit" router and rename to "manual"
> ------------------------------------------------------
>                 Key: SOLR-6630
>                 URL:
>             Project: Solr
>          Issue Type: Task
>          Components: SolrCloud
>            Reporter: Shawn Heisey
>            Priority: Blocker
>             Fix For: master (7.0)
>         Attachments: SOLR-6630.patch
> I had this exchange with an IRC user named "kindkid" this morning:
> {noformat}
> 08:30 < kindkid> I'm using sharding with the implicit router, but I'm seeing
>                  all my documents end up on just one of my 24 shards. What
>                  might be causing this? (4.10.0)
> 08:35 <@elyograg> kindkid: you used the implicit router.  that means that
>                   documents will be indexed on the shard you sent them
> to, not
>                   routed elsewhere.
> 08:37 < kindkid> oh. wow. not sure where I got the idea, but I was under the
>                  impression that implicit router would use a hash of the
>                  uniqueKey modulo number of shards to pick a shard.
> 08:38 <@elyograg> I think you probably wanted the compositeId router.
> 08:39 <@elyograg> implicit is not a very good name.  It's technically
> correct,
>                   but the meaning of the word is not well known.
> 08:39 <@elyograg> "manual" would be a better name.
> {noformat}
> The word "implicit" has a very specific meaning, and I think it's
> absolutely correct terminology for what it does, but I don't think that
> it's very clear to a typical person.  This is not the first time I've
> encountered the confusion.
> Could we deprecate the implicit name and use something much more
> descriptive and easily understood, like "manual" instead?  Let's go
> ahead and accept implicit in 5.x releases, but issue a warning in the
> log.  Maybe we can have a startup system property or a config option
> that will force the name to be updated in zookeeper and get rid of the
> warning.  If we do this, my bias is to have an upgrade to 6.x force the
> name change in zookeeper.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message