lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Rowe (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (LUCENE-4960) Require minimum ivy version
Date Mon, 28 Aug 2017 15:40:00 GMT

     [ https://issues.apache.org/jira/browse/LUCENE-4960?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Steve Rowe updated LUCENE-4960:
-------------------------------
    Attachment: LUCENE-4960.patch

Patch causing the build to fail when a regex matches disallowed Ivy jars: those with versions
2.0.*, 2.1.*, and 2.2.*.

Committing shortly.

> Require minimum ivy version
> ---------------------------
>
>                 Key: LUCENE-4960
>                 URL: https://issues.apache.org/jira/browse/LUCENE-4960
>             Project: Lucene - Core
>          Issue Type: Bug
>          Components: general/build
>    Affects Versions: 4.2.1
>            Reporter: Shawn Heisey
>            Priority: Minor
>         Attachments: LUCENE-4960.patch
>
>
> Someone on solr-user ran into a problem while trying to run 'ant idea' so they could
work on Solr in their IDE.  [~steve_rowe] indicated that this is probably due to IVY-1194,
requiring an ivy jar upgrade.
> The build system should check for a minimum ivy version, just like it does with ant.
 The absolute minimum we require appears to be 2.2.0, but do we want to make it 2.3.0 due
to IVY-1388?
> I'm not sure how to go about checking the ivy version.  Checking the ant version is easy
because it's ant itself that does the checking.
> There might be other component versions that should be checked too.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message