lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Langenmaier (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-11049) Solr in cloud mode silently fails uploading a big LTR model
Date Wed, 02 Aug 2017 11:00:08 GMT

    [ https://issues.apache.org/jira/browse/SOLR-11049?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16110708#comment-16110708
] 

Stefan Langenmaier commented on SOLR-11049:
-------------------------------------------

[~shalinmangar] - thanks for the clarification :)

> Solr in cloud mode silently fails uploading a big LTR model
> -----------------------------------------------------------
>
>                 Key: SOLR-11049
>                 URL: https://issues.apache.org/jira/browse/SOLR-11049
>             Project: Solr
>          Issue Type: Bug
>      Security Level: Public(Default Security Level. Issues are Public) 
>          Components: contrib - LTR
>         Environment: tested with Solr 6.6 an integrated zookeeper
>            Reporter: Stefan Langenmaier
>         Attachments: SOLR-11049.patch
>
>
> Hi,
> I'm using Solr in cloud mode, I have a MultipleAdditiveTreesModel with about 3MB in size.
When I upload the model with
> {noformat}
> curl -v -XPUT 'http://localhost:8983/solr/tmdb/schema/model-store' --data-binary @/big-tree.model
-H 'Content-type:application/json'
> {noformat}
> I get the following response
> {code:html}
> {
>   "responseHeader":{
>     "status":0,
>     "QTime":24318}
> }
> {code}
> This looks kind of slow but without an error. When I check the config the model is not
visible and when I try to run a query that uses the model I get the following error
> {code:html}
> "error":{
>     "metadata":[
>       "error-class","org.apache.solr.common.SolrException",
>       "root-error-class","org.apache.solr.common.SolrException"],
>     "msg":"cannot find model bigTreeModel",
>     "code":400}
> {code}
> When I upload the model to solr where I increased the zookeeper znode size limit with
> {noformat}
> -Djute.maxbuffer=0x1ffffff
> {noformat}
> the same model upload succeeds much faster
> {code:html}
> {
>   "responseHeader":{
>     "status":0,
>     "QTime":689}
> }
> {code}
> The model is visible in the configuration and queries that use it run without error.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message