lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Rowe (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (SOLR-11181) Deploying Maven artifacts (generate-maven-artifacts) pushes the same artifacts multiple times
Date Thu, 24 Aug 2017 13:47:00 GMT

     [ https://issues.apache.org/jira/browse/SOLR-11181?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Steve Rowe reopened SOLR-11181:
-------------------------------

Since I pushed this change, all Maven builds have failed on Jenkins, e.g. from [https://builds.apache.org/job/Lucene-Solr-Maven-master/2096/]:

{noformat}
-validate-maven-dependencies:
[artifact:dependencies] [INFO] snapshot org.apache.lucene:lucene-codecs:8.0.0-SNAPSHOT: checking
for updates from sonatype.releases
[artifact:dependencies] Downloading: org/apache/lucene/lucene-codecs/8.0.0-SNAPSHOT/lucene-codecs-8.0.0-SNAPSHOT.pom
from repository sonatype.releases at https://oss.sonatype.org/content/repositories/releases
[artifact:dependencies] Unable to locate resource in repository
[artifact:dependencies] [INFO] Unable to find resource 'org.apache.lucene:lucene-codecs:pom:8.0.0-SNAPSHOT'
in repository sonatype.releases (https://oss.sonatype.org/content/repositories/releases)
[artifact:dependencies] [INFO] snapshot org.apache.lucene:lucene-core:8.0.0-SNAPSHOT: checking
for updates from sonatype.releases
[artifact:dependencies] Downloading: org/apache/lucene/lucene-core/8.0.0-SNAPSHOT/lucene-core-8.0.0-SNAPSHOT.pom
from repository sonatype.releases at https://oss.sonatype.org/content/repositories/releases
[artifact:dependencies] Unable to locate resource in repository
[artifact:dependencies] [INFO] Unable to find resource 'org.apache.lucene:lucene-core:pom:8.0.0-SNAPSHOT'
in repository sonatype.releases (https://oss.sonatype.org/content/repositories/releases)
[artifact:dependencies] Downloading: org/apache/lucene/lucene-codecs/8.0.0-SNAPSHOT/lucene-codecs-8.0.0-SNAPSHOT.jar
from repository sonatype.releases at https://oss.sonatype.org/content/repositories/releases
[artifact:dependencies] Unable to locate resource in repository
[artifact:dependencies] [INFO] Unable to find resource 'org.apache.lucene:lucene-codecs:jar:8.0.0-SNAPSHOT'
in repository sonatype.releases (https://oss.sonatype.org/content/repositories/releases)
[artifact:dependencies] Downloading: org/apache/lucene/lucene-core/8.0.0-SNAPSHOT/lucene-core-8.0.0-SNAPSHOT.jar
from repository sonatype.releases at https://oss.sonatype.org/content/repositories/releases
[artifact:dependencies] Unable to locate resource in repository
[artifact:dependencies] [INFO] Unable to find resource 'org.apache.lucene:lucene-core:jar:8.0.0-SNAPSHOT'
in repository sonatype.releases (https://oss.sonatype.org/content/repositories/releases)
[artifact:dependencies] An error has occurred while processing the Maven artifact tasks.
[artifact:dependencies]  Diagnosis:
[artifact:dependencies] 
[artifact:dependencies] Unable to resolve artifact: Missing:
[artifact:dependencies] ----------
[artifact:dependencies] 1) org.apache.lucene:lucene-codecs:jar:8.0.0-SNAPSHOT
[artifact:dependencies] 
[artifact:dependencies]   Try downloading the file manually from the project website.
[artifact:dependencies] 
[artifact:dependencies]   Then, install it using the command: 
[artifact:dependencies]       mvn install:install-file -DgroupId=org.apache.lucene -DartifactId=lucene-codecs
-Dversion=8.0.0-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file
[artifact:dependencies] 
[artifact:dependencies]   Alternatively, if you host your own repository you can deploy the
file there: 
[artifact:dependencies]       mvn deploy:deploy-file -DgroupId=org.apache.lucene -DartifactId=lucene-codecs
-Dversion=8.0.0-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
[artifact:dependencies] 
[artifact:dependencies]   Path to dependency: 
[artifact:dependencies]   	1) org.apache.lucene:lucene-test-framework:jar:8.0.0-SNAPSHOT
[artifact:dependencies]   	2) org.apache.lucene:lucene-codecs:jar:8.0.0-SNAPSHOT
[artifact:dependencies] 
[artifact:dependencies] 2) org.apache.lucene:lucene-core:jar:8.0.0-SNAPSHOT
[artifact:dependencies] 
[artifact:dependencies]   Try downloading the file manually from the project website.
[artifact:dependencies] 
[artifact:dependencies]   Then, install it using the command: 
[artifact:dependencies]       mvn install:install-file -DgroupId=org.apache.lucene -DartifactId=lucene-core
-Dversion=8.0.0-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file
[artifact:dependencies] 
[artifact:dependencies]   Alternatively, if you host your own repository you can deploy the
file there: 
[artifact:dependencies]       mvn deploy:deploy-file -DgroupId=org.apache.lucene -DartifactId=lucene-core
-Dversion=8.0.0-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
[artifact:dependencies] 
[artifact:dependencies]   Path to dependency: 
[artifact:dependencies]   	1) org.apache.lucene:lucene-test-framework:jar:8.0.0-SNAPSHOT
[artifact:dependencies]   	2) org.apache.lucene:lucene-core:jar:8.0.0-SNAPSHOT
[artifact:dependencies] 
[artifact:dependencies] ----------
[artifact:dependencies] 2 required artifacts are missing.
[artifact:dependencies] 
[artifact:dependencies] for artifact: 
[artifact:dependencies]   org.apache.lucene:lucene-test-framework:jar:8.0.0-SNAPSHOT
[artifact:dependencies] 
[artifact:dependencies] from the specified remote repositories:
[artifact:dependencies]   central (http://repo1.maven.org/maven2),
[artifact:dependencies]   Nexus (http://repository.apache.org/snapshots),
[artifact:dependencies]   sonatype.releases (https://oss.sonatype.org/content/repositories/releases)
[artifact:dependencies] 
[artifact:dependencies] 
{noformat}

> Deploying Maven artifacts (generate-maven-artifacts) pushes the same artifacts multiple
times
> ---------------------------------------------------------------------------------------------
>
>                 Key: SOLR-11181
>                 URL: https://issues.apache.org/jira/browse/SOLR-11181
>             Project: Solr
>          Issue Type: Bug
>      Security Level: Public(Default Security Level. Issues are Public) 
>          Components: Build
>    Affects Versions: 6.6, master (8.0), 7.1
>            Reporter: Lynn Monson
>            Assignee: Steve Rowe
>            Priority: Minor
>             Fix For: master (8.0), 7.1
>
>         Attachments: SOLR-11181.patch, SOLR-11181.patch
>
>
> When following the instructions in the README.maven file, and watching the wire traffic,
the build system issues HTTP PUT operations for the same artifacts multiple times.   For example,
issuing this command:
>       ant -Dm2.repository.id=my-repo-id \
>           -Dm2.repository.url=http://example.org/my/repo \
>           generate-maven-artifacts
> from the lucene/ directory will generate redundant puts.  For example:
> PUT /<path>/org/apache/lucene/lucene-core/<version>/lucene-core-4.10.4-fs.31-sources.jar

> PUT /<path>/org/apache/lucene/lucene-core/<version>/lucene-core-4.10.4-fs.31-sources.jar.sha1

> PUT /<path>/org/apache/lucene/lucene-core/<version>/lucene-core-4.10.4-fs.31-sources.jar.md5
> ...
> PUT /<path>/org/apache/lucene/lucene-core/<version>/lucene-core-4.10.4-fs.31-sources.jar

> ...
> The maven repo I am using does not allow the second PUT and, hence, the build fails.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message