lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Rowe (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (LUCENE-7932) Search record with field value='a' or 'A' returns all records along with one more field value
Date Fri, 18 Aug 2017 18:19:01 GMT

     [ https://issues.apache.org/jira/browse/LUCENE-7932?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Steve Rowe updated LUCENE-7932:
-------------------------------
    Fix Version/s:     (was: 6.6)
                       (was: trunk)
                       (was: Positions Branch)

> Search record with field value='a' or 'A' returns all records along with one more field
value
> ---------------------------------------------------------------------------------------------
>
>                 Key: LUCENE-7932
>                 URL: https://issues.apache.org/jira/browse/LUCENE-7932
>             Project: Lucene - Core
>          Issue Type: Bug
>          Components: core/queryparser
>    Affects Versions: 6.6
>         Environment: Windows and Linux
>            Reporter: Rohit Balekundri
>            Priority: Critical
>              Labels: features
>
> 1.	I found all records are showing result if we pass value 'a' or 'A' as search value
along with either LocationCode=1 OR CollectionObjectID=1. Only seems to be happening for the
character a. I feel it's having similar issue in older Lucene version (Ex:5.3) as well. It's
Lucene code after making query it's returning all records.
> 2.	We have two solutions for above existing problem.
> a)	Either to allow to show all records if user enters 'a' or 'A' in search field. Not
correct.
> b)	Set value to "null" if user enters 'a' or 'A' in search field value and don't show
any records. Example: LocationCode=1 and Category='A' then it should not show any records.
> But this has side effect about if real record exist with same criteria then it will not
show that record. 
> c)	Test with other new releases from Lucene and search. 
> But later i found even Lucene 6.6 is also having same bug.
> This bug was found by our USA team.
> It's very urgent, needed to be fixed from Lucene team.
> Kindly consider this bug on top priority.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message