lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cassandra Targett (JIRA)" <>
Subject [jira] [Commented] (SOLR-7733) remove/rename "optimize" references in the UI.
Date Mon, 23 Oct 2017 16:20:00 GMT


Cassandra Targett commented on SOLR-7733:

bq. I'm targeting a section like that to be part of the resolution to LUCENE-7976

That sounds fine to me.

bq. I'm also planning on changing some/all references to optimize to forceMerge to make it
less attractive.

Also fine, but if there are any cases where the parameter is actually named "optimize" the
docs need to refer to it as that. We can't have the docs say it's called "forceMerge" and
it's really "optimize". So the docs change can only occur if and when the terminology change
is baked into the application and only where it's applicable if optimize is not changed globally.

> remove/rename "optimize" references in the UI.
> ----------------------------------------------
>                 Key: SOLR-7733
>                 URL:
>             Project: Solr
>          Issue Type: Improvement
>          Components: Admin UI
>    Affects Versions: 5.3, 6.0
>            Reporter: Erick Erickson
>            Assignee: Erick Erickson
>            Priority: Minor
>         Attachments: SOLR-7733.patch, SOLR-7733.patch
> Since optimizing indexes is kind of a special circumstance thing, what do we think about
removing (or renaming) optimize-related stuff on the core admin and core overview pages? The
"optimize" button is already gone from the core admin screen (was this intentional?).
> My personal feeling is that we should remove this entirely as it's too easy to think
"Of course I want my index optimized" and "look, this screen says my index isn't optimized,
that must mean I should optimize it".
> The core admin screen and the core overview page both have an "optimized" checkmark,
I propose just removing it from the "overview" page and on the "core admin" page changing
it to "Segment Count #". NOTE: the "overview" page already has a "Segment Count" entry.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message