lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Gerlowski (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-11514) Solr 7.1 does not honor values specified in solr.in.sh
Date Sat, 21 Oct 2017 19:22:00 GMT

    [ https://issues.apache.org/jira/browse/SOLR-11514?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16214082#comment-16214082
] 

Jason Gerlowski commented on SOLR-11514:
----------------------------------------

The {{install_solr_service.sh}} has some behavior that's maybe not the most intuitive.  It
installs Solr from a fresh extraction of the solr-7.1.0.tgz file, not the already-extracted
directory structure containing the install-script you're running in the command posted above.
 So if your {{solr.in.sh}} changes live next to the {{install_solr_service.sh}} script you're
running, they aren't being installed with Solr.

So in short, I suspect you just changed the wrong configuration file.

To verify this, can you check {{/etc/default/solr.in.sh}} on your test machine and let us
know whether it contains the config changes you're expecting.  If it doesn't, please add the
configuration lines, and hopefully that should allow you to see the changes you're expecting.
 Please let us know if that doesn't fix things.

> Solr 7.1 does not honor values specified in solr.in.sh
> ------------------------------------------------------
>
>                 Key: SOLR-11514
>                 URL: https://issues.apache.org/jira/browse/SOLR-11514
>             Project: Solr
>          Issue Type: Bug
>      Security Level: Public(Default Security Level. Issues are Public) 
>          Components: release-scripts, SolrCloud
>    Affects Versions: 7.1
>         Environment: Linux RHEL 7, 8GB RAM, 60GB HDD, Solr 7.1 in cloud mode (zookeeper
3.4.10)
>            Reporter: Howard Black
>
> Just installed Solr 7.1 and zookeeper 3.4.10 into a test environment and it seems that
arguments in the solr.in.sh file in /etc/default are not getting picked up when starting the
server.
> I have this specified in solr.in.sh SOLR_JAVA_MEM="-Xms512m -Xmx6144m" but the JVM shows
-Xms512m -Xmx512m.
> Same goes for SOLR_LOGS_DIR=/mnt/logs  logs are still being written to /opt/solr/server/logs
> The command I used to install Solr is this:
> ./install_solr_service.sh /home/hblack/solr-7.1.0.tgz -i /opt -d /mnt/solr-home -s solr
-u solr



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message