lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Howard Black (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-11514) Solr 7.1 does not honor values specified in solr.in.sh
Date Mon, 23 Oct 2017 18:10:00 GMT

    [ https://issues.apache.org/jira/browse/SOLR-11514?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16215553#comment-16215553
] 

Howard Black commented on SOLR-11514:
-------------------------------------

This is from the ./install_solr_service.sh script.

[root@solr-node01 bin]# ./install_solr_service.sh /home/hlblack/solr-7.1.0.tgz -i /opt -d
/mnt/solr-home/ -s solr -u solr

Extracting /home/hlblack/solr-7.1.0.tgz to /opt


Installing symlink /opt/solr -> /opt/solr-7.1.0 ...


Installing /etc/init.d/solr script ...


Installing /etc/default/solr.in.sh ...


/mnt/solr-home//data/solr.xml already exists. Skipping install ...


/mnt/solr-home//log4j.properties already exists. Skipping install ...

Service solr installed.
Customize Solr startup configuration in /etc/default/solr.in.sh
Waiting up to 180 seconds to see Solr running on port 8983 [\]  
Started Solr server on port 8983 (pid=10171). Happy searching!

    
Found 1 Solr nodes: 

Solr process 10171 running on port 8983
{
  "solr_home":"/mnt/solr-home/data",
  "version":"7.1.0 84c90ad2c0218156c840e19a64d72b8a38550659 - ubuntu - 2017-10-13 16:15:59",
  "startTime":"2017-10-23T18:06:14.533Z",
  "uptime":"0 days, 0 hours, 0 minutes, 8 seconds",
  "memory":"43 MB (%8.8) of 490.7 MB"}

[root@solr-node01 bin]# 


If I modify the /etc/default/solr.in.sh file, nothing gets picked up.

> Solr 7.1 does not honor values specified in solr.in.sh
> ------------------------------------------------------
>
>                 Key: SOLR-11514
>                 URL: https://issues.apache.org/jira/browse/SOLR-11514
>             Project: Solr
>          Issue Type: Bug
>      Security Level: Public(Default Security Level. Issues are Public) 
>          Components: release-scripts, SolrCloud
>    Affects Versions: 7.1
>         Environment: Linux RHEL 7, 8GB RAM, 60GB HDD, Solr 7.1 in cloud mode (zookeeper
3.4.10)
>            Reporter: Howard Black
>         Attachments: solr, solr.in.sh
>
>
> Just installed Solr 7.1 and zookeeper 3.4.10 into a test environment and it seems that
arguments in the solr.in.sh file in /etc/default are not getting picked up when starting the
server.
> I have this specified in solr.in.sh SOLR_JAVA_MEM="-Xms512m -Xmx6144m" but the JVM shows
-Xms512m -Xmx512m.
> Same goes for SOLR_LOGS_DIR=/mnt/logs  logs are still being written to /opt/solr/server/logs
> The command I used to install Solr is this:
> ./install_solr_service.sh /home/hblack/solr-7.1.0.tgz -i /opt -d /mnt/solr-home -s solr
-u solr



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message