lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Collins (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SOLR-11579) Building Solr using Java 9 and Maven doesn't work
Date Mon, 30 Oct 2017 17:49:00 GMT

     [ https://issues.apache.org/jira/browse/SOLR-11579?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Daniel Collins updated SOLR-11579:
----------------------------------
    Description: 
I'm calling this minor as I don't believe we officially support Java 9 (but correct me if
I'm wrong), and I've only tried on master (again, I don't *think* branch_7x is setup for Java
9?)

Several issues/notes:
# enforcer plugin breaks if you try to do mvn install
# javadoc plugin breaks if you try to do mvn javadoc:jar
# warnings from groovy-maven-plugin (TODO)
# a lot of the maven plugins are quite old
# forbiddenapis has some issues with Solr (I assume due to module split-up, javax is no longer
part of core) (TODO)

I have patches for 1, 2, and 4. Still working on 3 and 5.


  was:
I'm calling this minor as I don't believe we officially support Java 9 (but correct me if
I'm wrong), and I've only tried on master (again, I don't *think* branch_7x is setup for Java
9?)

Several issues/notes:
# enforcer plugin breaks as soon if you try to do mvn install
# javadoc plugin breaks if you try to do mvn javadoc:jar
# warnings from groovy-maven-plugin (TODO)
# a lot of the maven plugins are quite old
# forbiddenapis has some issues with Solr (I assume due to module split-up, javax is no longer
part of core) (TODO)

I have patches for 1, 2, and 4. Still working on 3 and 5.



> Building Solr using Java 9 and Maven doesn't work
> -------------------------------------------------
>
>                 Key: SOLR-11579
>                 URL: https://issues.apache.org/jira/browse/SOLR-11579
>             Project: Solr
>          Issue Type: New Feature
>      Security Level: Public(Default Security Level. Issues are Public) 
>          Components: Build
>    Affects Versions: master (8.0)
>         Environment: Apache Maven 3.5.0 (ff8f5e7444045639af65f6095c62210b5713f426; 2017-04-03T20:39:06+01:00)
> Maven home: /Users/dcollins53/Utils/apache-maven-3.5.0
> Java version: 9, vendor: Oracle Corporation
> Java home: /Library/Java/JavaVirtualMachines/jdk-9.jdk/Contents/Home
> Default locale: en_GB, platform encoding: UTF-8
> OS name: "mac os x", version: "10.12.6", arch: "x86_64", family: "mac"
> java version "9"
> Java(TM) SE Runtime Environment (build 9+181)
> Java HotSpot(TM) 64-Bit Server VM (build 9+181, mixed mode)
>            Reporter: Daniel Collins
>            Priority: Minor
>              Labels: maven, maven-enforcer-plugin
>
> I'm calling this minor as I don't believe we officially support Java 9 (but correct me
if I'm wrong), and I've only tried on master (again, I don't *think* branch_7x is setup for
Java 9?)
> Several issues/notes:
> # enforcer plugin breaks if you try to do mvn install
> # javadoc plugin breaks if you try to do mvn javadoc:jar
> # warnings from groovy-maven-plugin (TODO)
> # a lot of the maven plugins are quite old
> # forbiddenapis has some issues with Solr (I assume due to module split-up, javax is
no longer part of core) (TODO)
> I have patches for 1, 2, and 4. Still working on 3 and 5.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message