lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aditya Srinivasan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-11696) /query page generates http link that loads incorrectly-encoded url
Date Tue, 16 Jan 2018 17:36:00 GMT

    [ https://issues.apache.org/jira/browse/SOLR-11696?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16327435#comment-16327435
] 

Aditya Srinivasan commented on SOLR-11696:
------------------------------------------

I saw the "easy fix" label here and thought I'd work on this. Would the owners mind assigning
this to me? It would be my first PR/fix and I'd appreciate guidance in executing this as well!

> /query page generates http link that loads incorrectly-encoded url
> ------------------------------------------------------------------
>
>                 Key: SOLR-11696
>                 URL: https://issues.apache.org/jira/browse/SOLR-11696
>             Project: Solr
>          Issue Type: Bug
>      Security Level: Public(Default Security Level. Issues are Public) 
>          Components: website
>            Reporter: stuart robinson
>            Priority: Major
>              Labels: easyfix, newbie, website
>
> i'm trying to query documents that contain both "Covers for Modular Outdoor Club Chairs"
and "Resort Club & Ottoman Set" in my "vv" array field.
> that single ampersand seems to breaking the default url encoding that is generated in
my browser (Chrome 62.0.3202.94) when i click the search link generated at the top of the
/query page of the solr UI.
> in the UI, my q is
> {code}
> vv:"Covers for Modular Outdoor Club Chairs" && vv:"Resort Club & Ottoman
Set"
> {code}
> the UI generates the following url.  when I click it, i get different results from the
results in the /query UI
> {code}
> http://localhost:8983/solr/films/select?q=vv:"Covers for Modular Outdoor Club Chairs"
&& vv:"Resort Club & Ottoman Set"
> {code}
> because the url gets encoded wrong.  Resultant url seen in browser:
> {code}
> http://localhost:8983/solr/films/select?q=vv:%22Covers%20for%20Modular%20Outdoor%20Club%20Chairs%22%20&&%20vv:%22Resort%20Club%20&%20Ottoman%20Set%22
> {code}
> Properly-encoded url that leads to correct results:
> {code}
> http://localhost:8983/solr/films/select?q=vv%3A%22Covers%20for%20Modular%20Outdoor%20Club%20Chairs%22%20%26%26%20vv%3A%22Resort%20Club%20%26%20Ottoman%20Set%22
> {code}
> (encoded using https://www.urlencoder.org/)
> if the Solr UI is to generate a clickable link that appears to be equivalent to the UI's
search, then it ought to link to the correct search.
> i'm listing this as a "bug" even though it seems to be more of a "flaw" because it's
an issue that breaks the user experience and leads to unexpected results.  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message