lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron LaBella (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (SOLR-11694) Remove extremely outdated UIMA contrib module
Date Thu, 20 Sep 2018 19:08:04 GMT

    [ https://issues.apache.org/jira/browse/SOLR-11694?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16622539#comment-16622539
] 

Aaron LaBella edited comment on SOLR-11694 at 9/20/18 7:08 PM:
---------------------------------------------------------------

Hi Team,

How do we undo this commit/decision?

We use UIMA and SOLR +*every day*+ in production, and this decision will effectively freeze
us on the last working Solr / UIMA version of 7.4.0.  Surely there are other folks out there
doing text analytics with even older versions of UIMA and wish to use the latest and greatest
solr?

 

ALso, even though SOLR/LUCENE "ship" with UIMA 2.3.1, I've been using UIMA 2.8.1 for 2+ years
by simply dropping in the more up-to-date JAR in the core-specific "lib" directory.  I'd
have to look through all the lucene stuff again, but, I'm quite certain the lucene support
for UIMA is still active as well, no?


was (Author: aaronlab):
Hi Team,

How do we undo this commit/decision?

We use UIMA and SOLR +*every day*+ in production, and this decision will effectively freeze
us on the last working Solr / UIMA version of 7.4.0.  Surely there are other folks out there
doing text analytics with even older versions of UIMA and wish to use the latest and greatest
solr?

> Remove extremely outdated UIMA contrib module
> ---------------------------------------------
>
>                 Key: SOLR-11694
>                 URL: https://issues.apache.org/jira/browse/SOLR-11694
>             Project: Solr
>          Issue Type: Improvement
>      Security Level: Public(Default Security Level. Issues are Public) 
>          Components: contrib - UIMA
>            Reporter: Cassandra Targett
>            Assignee: Alexandre Rafalovitch
>            Priority: Major
>             Fix For: 7.5, master (8.0)
>
>         Attachments: SOLR-11694.patch
>
>
> A user on the [solr-user mailing list back in June|https://mail-archives.apache.org/mod_mbox/lucene-solr-user/201706.mbox/%3CCANsk%2BC_PvZJ38AQ2VfzKRYSQn6c8b33kGvaXxR3qNS3GQ4VUKA%40mail.gmail.com%3E]
brought up the fact that IBM has bought Alchemy and keys are no longer available to use Solr's
UIMA contrib.
> Someone recently made a [similar comment|https://lucene.apache.org/solr/guide/7_1/uima-integration.html#comment_7174]
to the Solr Ref Guide page and asking for a patch.
> I know next to nothing about UIMA, but figured it's worth an issue to determine what
to do here. I think folks are saying it's no longer usable? Or maybe only usable by people
who already have keys (which will possibly expire at some point)?
> Anyone have an idea what needs to be done here? It seems we should have some kind of
answer, but if it's no longer usable perhaps we should retire the contrib.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message