lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erick Erickson (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (SOLR-12751) Multi word searching is not working getting random search results
Date Thu, 06 Sep 2018 15:08:00 GMT

     [ https://issues.apache.org/jira/browse/SOLR-12751?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Erick Erickson resolved SOLR-12751.
-----------------------------------
    Resolution: Not A Bug

This issue tracker is not a support portal. Please raise this question on the user's list
at solr-user@lucene.apache.org, see: (http://lucene.apache.org/solr/community.html#mailing-lists-irc)
there are a _lot_ more people watching that list who may be able to help and you'll probably
get responses much more quickly.

 

If it's determined that this really is a code issue or enhancement to Solr and not a configuration/usage
problem, we can raise a new JIRA or reopen this one.

 

Your problem is likely that the default operator is OR and Solr is doing exactly what you're
telling it to. &debug=query is your friend.

> Multi word searching is not working getting random search results
> -----------------------------------------------------------------
>
>                 Key: SOLR-12751
>                 URL: https://issues.apache.org/jira/browse/SOLR-12751
>             Project: Solr
>          Issue Type: Bug
>      Security Level: Public(Default Security Level. Issues are Public) 
>         Environment: I am currently running solr on Linux platform.
> NAME="Red Hat Enterprise Linux Server"
> VERSION="7.5"
> openjdk version "1.8.0_181"
>  
> AEM version: 6.2
>  
>  
>  
>  
>            Reporter: Jagadish Muddapati
>            Priority: Blocker
>              Labels: newbie
>
> I recently integrate solr to AEM and when i do search for multiple words the search results
are getting randomly.
>  
> search words: {color:#ff0000}*Intermodal schedule*{color}
> Results: First solr displaying the search results related to {color:#ff0000}Intermodal{color}
and after few pages I am seeing the serch term {color:#ff0000}schedule {color}related pages
randomly. I am not getting the results related to multi words on the page.
> For example: I am not seeing the results like [Terminals & *Schedules* | *Intermodal* |
Shipping Options ... page on starting and getting random results and the  [Terminals & *Schedules* | *Intermodal* |
Shipping Options *...* page displaying after the 40 results.
>  
> Here is the query on browser URL:
> [http://test-servername/content/nscorp/en/search-results.html?start=0&q=Intermodal+Schedule|http://servername/content/nscorp/en/search-results.html?start=0&q=Intermodal+Schedule]
>  
> I am using solr version 7.4
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message