lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cassandra Targett (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-12786) HTML reference guide has invalid links
Date Thu, 20 Sep 2018 14:17:00 GMT

    [ https://issues.apache.org/jira/browse/SOLR-12786?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16622115#comment-16622115
] 

Cassandra Targett commented on SOLR-12786:
------------------------------------------

Before you commit this, can you please tell me the version of Asciidoctor that you are using?
This looks very similar to a problem I saw using Asciidoctor 1.5.7 and higher, which changed
the way section IDs are created automatically.

In May I changed the {{solr-ref-guide/REAMDE.txt}} to provide instructions to force the installation
of Asciidoctor 1.5.6.2 instead of 1.5.7. The latter version will be installed by default if
you only install the {{jekyll-asciidoctor}} gem. (See https://git1-us-west.apache.org/repos/asf?p=lucene-solr.git;a=commit;h=7bb3e5c2482c7b73ed2dd26ff4be4613e7f44872)

The problem with this patch is that _everyone_ will need to be on v1.5.7 after these changes
in your patch. Anyone with an earlier Asciidoctor version will get errors because the way
the section IDs are created will be incorrect for them. We have no way to enforce this version
with build scripts, so I thought it was simpler to stay on an earlier version for the time
being.

> HTML reference guide has invalid links
> --------------------------------------
>
>                 Key: SOLR-12786
>                 URL: https://issues.apache.org/jira/browse/SOLR-12786
>             Project: Solr
>          Issue Type: Bug
>      Security Level: Public(Default Security Level. Issues are Public) 
>          Components: documentation
>    Affects Versions: master (8.0)
>            Reporter: Jan H√łydahl
>            Priority: Major
>         Attachments: SOLR-12786.patch
>
>
> The refguide build aborts due to this.
> Example: "updating-solr-s-include-files" should instead be "updating-solrs-include-files"
since apostrophe is not replaced with dash.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message